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Chapter 1 Using MicroView 

Section 1.1 Introducing MicroView 

Welcome to MicroView 3-D volume viewer & analysis tool. MicroView is a visualization and 
quantification tool for 2-dimensional and 3-dimensional data.  It complements GE Healthcare' 
MicroCT systems by offering a number of visualization and analysis tools for MicroCT data.  

1.1.1 Getting Help

MicroView has context-sensitive help attached to most dialog boxes and windows, including the 
main MicroView window. Press F1, select MicroView Help...  from the Help menu, or h at any time 
to view the MicroView quick-reference guide.

1.1.2 Support 

For additional help installing and using MicroView and its features please contact GE Healthcare  
Software Support.  

Email:  eXplore_microCT@med.ge.com  
GE Healthcare  
1-1510 Woodcock Street, London, ON N6H 5S1 Canada  
Tel: 1.800.682.5327  
Email: eXplore_microCT@med.ge.com  
http://gemedical.com/preclinical_imaging 

1.1.3 Revision History

                                                                                                                                                                                                                                                                                                                                                                                                                                           

Revision v1.02002-12-18jdg Initial release

Revision v1.12003-06-05jdg Updated with screenshots and 
new info

Revision v1.2.0-b22004-07-16jdg Updated for CUI-compliant 
MicroView 1.2.0-b2

Revision v2.0 - 2005-02-02 MicroView 2.0 release
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1.1.4 Copyright Information

MicroView may be freely distributed to multiple computers. 
MicroView is an open-source program, written in the C++ and Python-based programming 
language VTK.  To learn about Python please visit http://www.python.org. To learn about VTK 
please visit the Kitware website, the developers of VTK, at http://www.kitware.com.  
MicroView is based on a number of open source software packages. Individual copyright and 
license statements from their respective owners follow.  
GE Healthcare Systems Copyright 
Copyright (c) 2000-2005 GE Healthcare. 

EXCEPT WHEN OTHERWISE STATED IN WRITING BY THE COPYRIGHT HOLDERS AND/OR 
OTHER PARTIES, THE COPYRIGHT HOLDERS AND/OR OTHER PARTIES PROVIDE THE 
SOFTWARE "AS IS" WITHOUT EXPRESSED OR IMPLIED WARRANTY INCLUDING, BUT NOT 
LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A 
PARTICULAR PURPOSE.  IN NO EVENT UNLESS AGREED TO IN WRITING WILL ANY 
COPYRIGHT HOLDER OR OTHER PARTY WHO MAY MODIFY AND/OR REDISTRIBUTE THE 
SOFTWARE UNDER THE TERMS OF THIS LICENSE BE LIABLE FOR ANY DIRECT, INDIRECT, 
INCIDENTAL OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, LOSS OF 
DATA OR DATA BECOMING INACCURATE OR LOSS OF PROFIT OR BUSINESS 
INTERRUPTION) ARISING IN ANY WAY OUT OF THE USE OR INABILITY TO USE THE 
SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.  

ATAMAI INC. LICENSE 
Portions of MicroView are based on code provided by Atamai Inc. The Copyright and license 
statement follows:  
Copyright (c) 2000 Atamai, Inc. 
Use, modification and redistribution of the software, in source or binary forms, are permitted 
provided that the following terms and conditions are met: 

1. Redistribution of the source code, in verbatim or modified form, must retain the above 
copyright notice, this license, the following disclaimer, and any notices that refer to this license 
and/or the following disclaimer. 

2. Redistribution in binary form must include the above copyright notice, a copy of this license 
and the following disclaimer in the documentation or with other materials provided with the 
distribution. 

3. Modified copies of the source code must be clearly marked as such, and must not be 
misrepresented as verbatim copies of the source code. 

THE COPYRIGHT HOLDERS AND/OR OTHER PARTIES PROVIDE THE SOFTWARE "AS IS" 
WITHOUT EXPRESSED OR IMPLIED WARRANTY INCLUDING, BUT NOT LIMITED TO, THE 
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR 
PURPOSE.  IN NO EVENT SHALL ANY COPYRIGHT HOLDER OR OTHER PARTY WHO MAY 
MODIFY AND/OR REDISTRIBUTE THE SOFTWARE UNDER THE TERMS OF THIS LICENSE 
BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL OR CONSEQUENTIAL DAMAGES 
(INCLUDING, BUT NOT LIMITED TO, LOSS OF DATA OR DATA BECOMING INACCURATE OR 
LOSS OF PROFIT OR BUSINESS INTERRUPTION) ARISING IN ANY WAY OUT OF THE USE 
OR INABILITY TO USE THE SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH 
DAMAGES. 
VTK Copyright 
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Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen  
All rights reserved. 
Redistribution and use in source and binary forms, with or without modification, are permitted 
provided that the following conditions are met: 

1. Redistributions of source code must retain the above copyright notice, this list of conditions 
and the following disclaimer. 

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions 
and the following disclaimer in the documentation and/or other materials provided with the 
distribution. 

3. Neither name of Ken Martin, Will Schroeder, or Bill Lorensen nor the names of any contributors 
may be used to endorse or promote products derived from this software without specific prior 
written permission. 

4. Modified source versions must be plainly marked as such, and must not be misrepresented as 
being the original software. 

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS ``AS 
IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE 
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR 
PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHORS OR CONTRIBUTORS BE 
LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR 
CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF 
SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS 
INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN 
CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) 
ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE 
POSSIBILITY OF SUCH DAMAGE. 

Section 1.2 Installing MicroView  

To install MicroView. 
1. Insert CD and follow online instructions in the release-notes.html file to install program. 

The MicroView installation routine will place a MicroView launcher in the Applications folder of the 
Finder application, under Windows and << Mac specific info 

1.2.1 Minimum Windows System Specifications 

• Windows 98, NT 4.0, 2000, XP
• Processor: Pentium III, 450MHz  
• RAM: 256MB* 
• Hard Drive Space: 55MB  
• Video: 3-D accelerated video card with 64MB of texture memory** 
• 3 Button Mouse  
* The amount of RAM required depends on the size of the files you wish to view.  
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** MicroView will run using a video card with only 16MB of video RAM, however, a video card with 
32MB of video RAM and on board texture mapping support is recommended.  

1.2.2 Minimum Mac System Specifications 

• G3 computer
• MAC OS X 10.3.4 +
• Optional X11 components installed
• RAM: 32MB* 
• Hard Drive Space: 70MB  
• a 3-D accelerated video card with 64MB of texture memory **  
• 3 Button Mouse  
• SVGA monitor and graphics capabilities (1280x1024 resolution recommended)
• The user installing MicroView must have administrator privileges on the system where it will 

be installed. 
* The amount of RAM required depends on the size of the files you wish to view.  
** MicroView will run using a video card with only 16MB of video RAM, however, a video card with 
32MB of video RAM and on board texture mapping support is recommended.  

1.2.3 Learning MicroView  

This manual, together with the online will help you learn MicroView.  

MICROVIEW USER MANUAL  
This User Manual contains information on using the MicroView commands and features. 
The manual assumes you have a working knowledge of your computer and its operating 
conventions, including how to use a mouse and standard menus and commands.  It also assumes 
you know how to open, save, and close files.  For help with any of these techniques, please see 
your operating system documentation.  

HELP FUNCTION  
While running the program the help function is always available.  Press F1, select MicroView 
Help... from the Help menu or the h key at anytime and a help screen appears in a web browser.  
The help screen lists the commands, features, and program shortcuts.  
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Chapter 2 Using MicroView 
Use MicroView to view and analyze image files obtained using MicroCT. 

Section 2.1 Starting MicroView  

WINDOWS
1. Double-click GEMS MicroView icon located on desktop. 

Alternatively, open Start Menu and select MicroView from Programs/GE Healthcare/
MicroView/MicroView. 

2. Double-click the icon of any supported image file from within Window's Explorer or any file 
browser. MicroView is launched, and the selected image file is automatically loaded. 

MAC
1. Find the MicroView application icon in the Applications folder from the Finder window.

2. Double click on the MicroView application icon to start the program. 
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2.1.1  Loading a File 

1. Locate and select file and click Open to load file. Depending on the size of the selected volume 
this may take a few moments.  

NOTE- Files sizes which exceed the system RAM will not open. 

Once the file is loaded the volume appears on the screen. You now are ready to view and 
analyze the image data.  

2.1.2 Importing 2-D Image Slices 

MicroView is able to import a sequence of 2-D images in a variety of common image formats, and 
assemble them into a 3-D image.  

1. To do this each 2-D image file must be named with a sequential and consecutive number. 
2. Select Image Import... from the File menu. File Import window appears.

3. Enter a filename template name, in the format import-####.png, where # denotes characters 
that are automatically replaced by index numbers.  
The …  (browse) button to the right of the template box can be used to locate a file.  

4. Once selected, edit and replace the numbers with # marks to generate an appropriate filename 
template. 

5. Enter first and last index numbers in the appropriate entry boxes (e.g. if the template chosen 
is "import-##.gif" and the first and last numbers are set to 3 and 7, respectively, MicroView 
loads import-03.gif, import-04.gif... import-07.gif). 

6. Enter desired spacing between image slices, in millimeters for each of the x, y, and z axes. 
7. Enter the first and last number in the series of images to be imported. 
8. Press Import button to import and display the image sequences in MicroView.  



GE HEALTHCARE 
DIRECTION 2407688, REVISION 1 MICROVIEW GUIDE

Page 7  

2.1.2.1 Importing raw 2D images
MicroView can also import raw data in a variety of forms. 

1. Select Raw Image button on File Import window to display additional import options. 

2. Specify the offset from the beginning of each file to the raw image data (in case an image 
header is present), the data type, byte ordering (for 16-bit image data) and the dimensions of 
the raw image data. 

3. Click on Import button to import the file.
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2.1.3 Main MicroView Window  

The default MicroView display consists of an application toolbar on the left side of the screen, a 3D 
image viewport in the centre of the screen, and three 2D viewports on the right side of the screen. 
It also contains a menu at the top of the application window, Window and Level adjustment slide 
bars at the bottom and a status and progress indicator at the bottom of the window.
If the volume loads into MicroView and the viewports seem to be empty you may have to adjust 
the Window / Level values and/or move through the planes to see the data. See details below. 

Tool bar

3-D Viewport

2-D Viewports

LevelWindow level
Status bar

Menu bar

Progress Indicator

Slide to adjust; double click to close toolbar

Click to launch
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2.1.3.1 Modifying the display
Each viewport in MicroView can be individually maximized or expanded by double-clicking mouse 
button 1 over the viewport. Restore the display by double-clicking mouse button 1 again. 

The basic layout of MicroView can also be changed: Select Window->Set Layout to 2-by-2 to 
display MicroView as a 2-by-2 grid of viewports. Select Window->Set Layout to 1-by-3 to switch 
back to the default arrangement. 
The toolbar on the left of the screen can be resized or minimized by double clicking the 

2.1.3.2 Image viewing  
If you are not familiar with working with 3-dimensional digital images it may take some time to 
become comfortable with rotating and manipulating your data. 

VIEWING DATA  
Once the file is loaded into MicroView you may need to adjust the Window / Level values to 
properly view the data.  

1. Use cursor to slide Window and Level bars to an appropriate value. The image adjusts 
accordingly.  

2. Right-click on either scrollbar to get a context sensitive menu that can be used to manually 
enter scrollbar values and to adjust scrollbar behavior. 

1 by 3 display                                                                Expanded view

2 by 2 display                                                          Expanded view 2D
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• Immediate Updates: Window and Level values adjust as you scroll.
• Delayed Updates: Changes to Window and Level values occur once you release the mouse 

button. This feature is useful for slow displays.  

MOUSE & CURSOR
Using MicroView requires a 3-button mouse.   
Button 1 is left-most button and button 3 is right-most button. The mouse can be used at any time 
to perform the functions described below.  

Right-click to adjust

Button 

1                  2                  3
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CURSOR 
The MicroView cursor changes appearance depending on where it is on the screen and what you 
are doing.

appears when using button 2 to move planes through the volume 

appears when using button 1 to rotate 3-D volume 

appears when using shift and button 1 to pan / re-position 2-D images 

appears when using button 3 to zoom 3-D volume or 2-D images 

2.1.3.3 Rotating volume

1. Hold button 1   and move cursor to rotate the volume.  
Press r key at any time to reset volume to starting position. 

 

2.1.3.4 Panning volume  

1. Use Shift + button 1     and drag cursor to re-position volume on the screen.  
Press r key at any time to reset volume to starting position. 
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2.1.3.5 Slicing through selected planes

1. Use button 2   with cursor in the inner area of the plane to move selected plane across 
volume. 

NOTE- Press the z key to toggle the setting. This causes the planes to move in increments  
that have been determined by the volume spacing value.

Alternatively, move though selected planes by positioning cursor on a plane within 3-D or 2-D 
viewport and press arrow keys to move plane back and forth through volume. Plane moves 
one voxel.  

2. Position cursor on a plane within 3-D or 2-D viewport and then press Page Up or Page Down 
key to move plane back and forth through the volume ten voxels at a time.  

3. Pressing the Home or End key will move the selected plane out to the edge of the volume. 

2.1.3.6 Rotating plane around its axis  

Use button 2    with cursor at the edge of the plane. 

1. Hold button 2 and drag cursor to rotate plane around its plane axes. 
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Depending on whether the cursor is located inside or outside the volume, the rotation behavior will 
vary.  

2.1.3.7 Zooming image  

Use Button 3    with cursor within 3-D or 2-D Viewport. 

1. Hold button 3 and move cursor up and down to zoom image in and out. 

RESETTING IMAGE  
Press r key at any time to reset volume to starting position. 
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2.1.3.8 Changing MicroView options  
MicroView allows you to control how the information on the screen is displayed.  

1. Select Application Setting… from Edit menu. 

The MicroView Options Dialog box appears. 
2. Select or de-select from among the display or miscellaneous features using checkboxes or 

shortcut keys shown adjacent to the options list.  

The display and miscellaneous options for which there are shortcut keys are shown below. 
 

Key Result 
e Toggles the intersection lines on the 2-D images on or off. 

f Toggles the borders around the planes on or off. 

l Toggles the screen background in the main window from black to gray. 

o Toggles the axes labels (X, Y, Z) on or off. 

k Toggles the axial plane on or off in the main window.

j Toggles the coronal plane on or off in the main window.

i Toggles the sagittal plane on or off in the main window.

x Highlights the labels on the screen. 

z Integer stepping. 
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The other display and miscellaneous options are explained below. 

Option Result

Show Volume Outline If enabled, shows an outline around the outside edge of 
the volume. 

Show measurements in mm The alternative unit of measure is in pixels.

Enable Integer Stepping If enabled, MicroView prevents the display of bilinearly 
interpolated slices between actual data slices.  

Update W(indow)/L(evel) 
immediately

If enabled, MicroView updates the image as the Window/
Level settings are changed.

Display Splash at Startup If enabled, MicroView displays a splash screen at 
program start up. 

Enable balloon help If enabled, MicroView displays popup help text over all 
dialog boxes when the cursor is stationary for a few 
seconds. 
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2.1.4  Saving Complete Image File  

The complete image file can be saved in a variety of different formats from within MicroView. 

1. Select Save As from File menu. 

2. Select destination folder, named and desired file format. Press Save. 

2.1.5 Saving 2-D Images  

2-D images from MicroView can be saved in a number of different file formats. 

1. Position cursor over 2-D plane or main 3-D volume and press t key.  
2. Select name and destination location to which the .tif file is to be saved.  Press Save. 

2.1.6 Exporting Images as 2-D Image Slices 

1. Select Image Export... from File menu.  
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2. Choose an image file format from the list provided. The available choices depends on the 
image depth of the selected image. 

3. Click OK. 
4. Select a directory to which to save the files. MicroView automatically saves individual image 

slices that make up the volume as individual files.  
5. The filename extension depend on the selected file format, and a prefix of "export-"  (e.g. 

export-0001.gif, ...) appears. 
6. Click OK. 
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Chapter 3  Working with CT Image 
MicroView contains a number of standard and optional tools to help you analyze two and three-
dimensional  data. These are described below. Optional tools are noted, and may be purchased by 
contacting GE Healthcare. See contact information at front of manual for further information. 

Section 3.1 MicroView Tools

3.1.1 Point Measurement (1-D) 

MicroView provides location and grayscale information for individual points on either 2-D or 3-D 
images. 
1. Place cursor on any point on 3-D volume or on 2-D plane.  

 
The coordinates and grayscale value of the point are continuously displayed in the bottom left-
hand corner of the main MicroView window.  

3.1.2 Line Measurement & Analysis (2-D) 

MicroView allows you to create lines on the 2-D planes for later analysis. Define a line using the 
following method. 

DEFAULT LINE
1. Select Show Line from the Edit menu. 

A line will appear in the middle of the volume. The line may be repositioned as described 
below. 

1. Position cursor over 

2. Information appears

    a point on volume
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CUSTOM LINE
1. Position cursor over an image plane in any of the viewports. Press 1 key to mark beginning of 

line.  
2. Re-position cursor over same plane to mark end of the line. Press 2 key.  

Green and blue indicate the end points of the new line and information about it appears in the 
upper-left corner of the screen.  

 
The line can be re-positioned in the viewport by selecting and dragging the markers with the 
middle button. 

3. Define new endpoints at any time by pressing either of the 1 and 2 keys. 
4. Clear line by pressing the y key, or selecting Clear Line from Edit menu. 

Once a line has been defined, use any of the following keys to perform 2-D analysis: 

3.1.3 Viewing Line Profiles  

The system can calculate and display a profile of the grayscale values along the line.  

1. Press p key or select Plot... from Tools menu to generate line profile.  
A typical window is shown below.

Key Result 

a Saves grayscale values along the selected line to a text file. 

p Plots the grayscale values along the selected line. 

0 Saves the end points of the selected line to a text file. 

y Removes the line. 

Define endpoints of line
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ZOOMING IN ON A REGION OF INTEREST (ROI) 
1. Use button 1 to click and drag a region of interest along the line profile and zoom in on the 

plotted data.  

Multiple levels of zooming can be achieved by repeating the click-and-drag method.  
2. Zoom out by clicking button 3.
3. Reset plot window at any time by clicking Reset button on plot window, or using r key. 

MEASURING ALONG 2D PIXEL PROFILE
This feature allows you to make measurements along a line much more accurately than can be 
done while working from the 3D volume itself. 

1. Position the mouse cursor over a feature within the plot window and press the 1 key, then 
select a second feature and press the 2 key. 
A horizontal red line is drawn between the two features. Mouse cursor position and selected 
line length are displayed in the bottom centre of the plot window.

Click and drag a region of interest
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3.1.3.1 Line profile options 
The line profile tool contains a number of options, described below. 

Button  Result 

Symbols  Toggles the display of symbols at each data point along the profile.  

Snapshot... Takes a snapshot of the plot window and saves it to disk an image file. System 
prompts for a file name, file type and destination for the file. Press Save. 

Save Data... Saves the line plot data to a .txt file. System prompts for a file name and 
destination for the file. Press Save. 

Reset Resets the view of the plot window. 
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3.1.4 Defining a Region of Interest Volume 2D / 3D

INTRODUCTION
For many operations in MicroView, the starting point is the selection of a 2D or 3D Region Of 
Interest (ROI). ROIs define the portion of the volume to be analyzed. For instance, an ROI can be 
created around a feature in an image in order to compute the mean and standard deviation of just 
that feature or perform some form of analysis. 

The active ROI in MicroView is typically displayed in yellow to differentiate it from other surfaces 
and voxel highlight tools. The ROI may appear as a transparent yellow surface, or as a grouping of 
yellow voxels in the displayed image plane, depending on the tool used to generate the ROI. 
There are five tools that can be used to generate a ROI in MicroView. These are: 
• Standard ROI Tool,
• Advanced ROI Tool,
• Region Grow Tool,
• Overlay Geometry Tool, 
• Cortical Bone ROI Tool. 
These are explained in detail in the following section. 

INSTRUCTIONS
MicroView allows you to create a 2D or 3D ROI from within the larger image volume.

1. Using cursor, mark start point on a plane within the volume. Press 7 key. 
2. Reposition cursor and mark an end point on a plane within the volume. Press 8 key. 

A yellow rectangle defining the sub-volume is drawn.  

Once a ROI is selected use the tools described below to do 2D/3D analysis on the volume.   

Simple ROI tool
IsoSurface Tool

Region Grow Tool
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3.1.5 Sub-Volume Analysis 

Once a sub-volume has been defined, a number of analyses can be performed using either the 
shortcut keys described below or the buttons on the histogram window.  

3.1.5.1 Plot histogram of sub-volume
1. Press g key to plot and display histogram from sub-volume.  
2. Select a box ROI as described previously, or select the entire image volume from within the 

Standard ROI Tool. 
3. Select Histogram… from Tools menu or press the g key. A histogram of the current Region of 

Interest is automatically calculated and shown in a separate window. 

ZOOM IN FOR FURTHER ANALYSIS
1. Using mouse button 1 click and drag an area of the histogram for further analysis. The blue 

graph will turn red where selected and the selected area will be displayed. 
2. Reset plot window at any time by clicking Reset button on plot window, or using r key. 

AUTO THRESHOLD
The Auto Threshold button can be used to automatically determine an optimal threshold value for  
the isosurface tool or stereology tool. 

Key Result 

g Plots the histogram and computes the mean and standard deviation of the 
grayscale values within the ROI

m Calculates mean and standard deviation for sub-volume. Value is displayed in 
lower right-hand corner of screen. 

s Saves the minimum coordinates of the sub-volume and difference between the 
minimum and maximum coordinates to a file called SubVolumeCoordinates (in the 
loaded file’s directory). 

v Saves the sub-volume file. System prompts for a file name, format and location. 
Click Save or Cancel upon completion.

c Clears the volume. 

d Save the grayscale values to an ASCII file. System prompts for a file name, format 
and location. Click Save or Cancel upon completion. 

If the sub-volume is a rectangular area (an area on single plane) the u key can be used to 
perform the following. 

u Save the area file. System prompts for a file name, format and location. Click Save 
or Cancel upon completion.
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SELECT RANGE OF VOXEL VALUES
You can select a range of voxel values, and the system will report the number of voxels in the 
selected range and the volume fraction. 

1. Place cursor on the graph in the plot window, press and hold down the mouse button 2. Drag 
the mouse until the desired range of voxel values have been highlighted. Release mouse 
button.
Volume and volume fraction information for the selected area are generated and displayed on 
screen.

The controls in the histogram window are similar to the controls in the 2D profile plot window. 
The histogram window does have some additional features, described below.

2. Check the Highlight selected region checkbox to adjust the texture mappings so that voxels 
corresponding to the selected value range are highlighted. 

SELECT BIN SIZE
The user can select the bin size. The bin size is the width of each of the bars in the histogram. The 
default bin size is 1. 
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The following commands are available on the histogram window. 

ZOOMING IN ON A REGION OF INTEREST (ROI) 
1. Use button 1 to click and drag a region of interest along the histogram plot and zoom in on the 

plotted data. 
 

Multiple levels of zooming can be achieved by repeating the click-and-drag method.  
2. Zoom out by clicking button 3.  
3. Reset plot window by clicking Reset button or press r key. 

Button/Function Result 

Snapshot Takes a snapshot of the histogram window and saves it to an image 
file. System prompts for a file name and destination for the file. Press 
Save or Cancel upon completion. 

Save Data Saves the histogram data to a .txt file. System prompts for a file name 
and destination for the file. Press Save or Cancel upon completion. 

Reset Resets the view of the histogram window to the starting position. 

Auto Threshold System automatically calculates an optimal threshold value for use 
in the Isosurface tool. 

Bin User can select appropriate bin size for histogram. 

Highlight Selected 
Region 

When selected, provides a visual indication of the selected area on 
the original image in red. 

Area selected for further analysis
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3.1.6 Region Of Interest (ROI) Selection - Standard

In addition to using the 7 and 8 keys (or Control-7 and Control-8) to quickly define a rectangular 
ROI, MicroView provides you with complete control over the size and location of the ROI using the 
Standard ROI tool. 

1. Select Standard ROI… from Tools menu. The Standard ROI toolbar appears. 

   
A yellow elliptical cylinder or parallelepiped appears in the volume.  

       
Define a ROI within the volume for analysis. 

1. Select either an elliptical cylinder or a parallelepiped volume for analysis.  
2. Select preferred unit of measure, millimeters or pixels.  
3. Adjust ROI size by dragging cursor along the X, Y or Z slider bars, or by entering an exact value 

in the text box. The ROI area changes automatically and the new values are displayed.  

1. Choose ROI shape

2. Select units

3. Adjust ROI size

4. Adjust ROI location

5. SeIect Whole Image
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NOTE- Press Shift key while dragging mouse to reposition the ROI.  

The selected ROI in the volume adjusts accordingly.  

ADJUSTING ROI SIZE  
The ROI size and position can be adjusted to suit.  

1. Click and drag cursor over the slider bar to shift the location of the ROI within 3-D volume. 
The yellow ROI in the volume shifts accordingly.  

2. Alternatively, adjust ROI size by clicking and dragging within the ROI using mouse button 2.

NOTE- You can also adjust the position of the ROI by moving the mouse to a new location 
and pressing 3. The ROI will move accordingly.   

ADJUSTING ROI POSITION
To change the location of the ROI center within the 3-D volume;  

1. Hold button 1 and drag mouse over any of the text boxes labeled, X Position, Y Position, or Z 
Position, to shift the corresponding position, or, press and hold the 3 key and use the mouse 
to reposition the area. Release the 3 to set the new coordinates.

NOTE- You can also adjust the position of the ROI by moving the mouse to a new location 
and pressing  3. The ROI will move accordingly.   

Once you have correctly defined the ROI you can begin the calculations using any of the 
optional plug-in analysis tools.  

2. Click X in upper corner to close Standard ROI Tool. 

Click to keep X and Y values equal
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3.1.7 Selecting a Region of Interest (ROI) - Advanced 

The Advanced ROI Tool can be used to generate a 3D ROI from a series of stacked 2D ROIs. It 
also allows you to manually select an arbitrary ROI or to define different shaped regions of interest 
such as spline-fitted surfaces. 
Once a ROI is selected, analysis such as calculating mean and standard deviation, generating an 
isosurface, calculating BMD, etc. can be performed. 

1. Select Advanced ROI… from Tool tab or Tools menu. The Advanced ROI toolbar appears.

 
2. Choose desired shape from the available options, (Rectangle, Ellipse, Polygon or Spline).
3. Click Start button to draw the 2D image. 

At any time, click Reset to delete all 2D and 3D ROIs. This action may not be undone. 

ROI AS RECTANGLE OR ELLIPSE
1. Position mouse within one of the 2D image panes, press mouse button 1 and drag to desired 

size.
2. To adjust the size of the 2D ROI place mouse on any corner of the ROI, press button 1 and 

drag to suit.  
Release button when proper size is reached. 

3. To adjust position of 2D ROI, place mouse inside of ROI, press and hold button 1 and drag. 
Release mouse button when the 2D ROI is positioned properly. 

4. Click mouse button 1 outside of 2D ROI to re-select and inside of the 2D ROI to drag it around. 
5. Push the 2D plane with the middle mouse button to a new location and draw another 2D ROI 

as described above.
6. Click Generate 3D ROI button to draw the 3D ROI. Save, load and interpolate the contours as 

required.   

1. Choose shape

2. Position contour

3. Manage contours

4. Construct the 3D ROI

5. Save the 3D ROI
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ROI AS POLYGON OR SPLINE
This free-hand mode is used to define a ROI as either a polygon or spline. 

1. Check either Polygon or Spline and Start button. 

2. Using the cursor and mouse button 1 pick and click the points which will define your shape on 
the 2D image pane. The points are connected automatically with line segments. 

3. Once fully defined, click again on the first point to enclose the ROI. 
4. To delete a point, put the mouse cursor over the point and hit the delete key. 

After the 2D ROI is enclosed, it can be edited by dragging a point to re-position it, clicking on 
a line segment to add a point, clicking inside the ROI to drag the whole ROI, or clicking outside 
of the ROI to erase the ROI and start all over. 

NOTE- For each user-drawn 2D ROI there is a number in the Key Frames section. A Key 
Frame is a number that indicates the image slice index where the 2D ROI was drawn. Click 
the Interpolate Contours button to generate 2D ROIs on every empty slice between the 
minimum and maximum Key Frames. There are two options for the interpolation: Linear or 
Spline. 

5. Push the 2D plane with the middle mouse button to a new location and define another shape  
as described above. Repeat as required until the boundaries of the new ROI have been 
completely defined. 

Select and click points 
  with button 1  
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6. Click Generate 3D ROI button to draw the 3D ROI. Save, load and interpolate the contours as 
required.   

7. After the interpolation, you can edit any frames to fine-tune the ROIs. Every edited frame  
becomes a Key Frame in addition to the existing Key Frames. Clicking on the Interpolate 
button will do the interpolation again using the updated Key Frames. 

8. Click Save Contours button at any time to save the stack of 2D ROIs. 
The 2D ROIs can be reloaded by clicking Load Contours button. 

9. To generate a 3D ROI from a stack of 2D ROIs and display the 3D ROI click the Generate 3D 
ROI button. 

10. Click on the ROI On or Off Radio button to show or hide the 3D ROI. 
11. Press Save... button to save the 3D ROI. 

This can be used by Overlay Geometry module. 
12. Click the x button in the top right hand side of the notebook tab to close this tab and remove 

ROIs from all image panes. This action may not be undone.

Pick and define 
contours on 2D 
planes

Generate 3D ROI
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3.1.8 Cortical ROI

1. Select a box ROI as described previously, or select the entire image volume. 
2. Select Cortical ROI... from Tools menu. The Cortical ROI toolbox appears. 

3. Set a graylevel value that selects bone versus non-bone.
4. Select Auto Threshold button. System automatically computes a threshold value and displays 

it on-screen.
5. Select hole & channel size (in pixels) and trabecular thickness (in pixels). (7 is the default 

value)
6. Select Run, to start the segmentation algorithm. Results are displayed on the screen. 
7. Select Segmentation -> ROI to convert the segmentation results to an ROI for use with the 

bone analysis tool. Results are displayed on the screen. 
8. Select Align to Principal Axes buttons to align the volume to the principal axes of the 

segmented volume. 

1. Set graylevel value

2. Run Auto Threshold

3. Select segmentation

4. Run segmentation

5. Convert results to an ROI

parameters
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3.1.9 DICOM Data Transfer Tool

MicroView  allows you to transfer a loaded image to a compatible DICOM viewing station for 
viewing, archiving or printing.   
It uses the Central Test Node (CTN)  third-party command line tool "send_image" to accomplish 
this. See http://wuerlim.wustl.edu/DICOM/ctn.html for further information. 

1. Select Dicom Transfer... from Tools menu.  Dicom Transfer toolbox appears.

2. Enter hostname and port number of the destination server in the text entry boxes. 
3. Optionally, select a DICOM application name (AE Title) for servers that require communication 

from a specific application name. 
For servers that do not require a specific application name, leave this field blank. 
Check with your DICOM vendor, or user's manual to determine what the AE (Application 
Entity) title should be.

4. Enter values for Patient Name, Patient ID, Study ID and Study Description, as required.
In some cases MicroView may provide default values based on the image loaded. 

5. Press Send Image button to transfer the image. 

To learn more about CTN and send_image, visit the CTN web site.
  



GE HEALTHCARE
DIRECTION 2407688, REVISION 1 MICROVIEW GUIDE

Page 34  

3.1.10 CT Calibration Tool 

This tool is used to measure three different ROIs within an image, and save/restore these values. 
The three ROIs are saved so that the reconstruction software can automatically determine air, water 
and bone calibration constants.  

1. Select CT Calibration Tool... from Plugins menu.  CT Calibration toolbar appears.

2. Define a ROI on the volume with only air using either the 7 & 8 keys, (or by using the ROI 
Selection Tool... on the MicroView menu) and

3. Clicking the corresponding Save button.  
4. Do the same for water and bone. Click Save. 
5. Once a ROI for each of air, water, and bone are selected and the settings have been saved, 

click Load buttons and the corresponding ROI appears.  
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3.1.11 Image Information Tool

The Image Information Tool displays information about the image, such as title, date of creation, 
size, spacing, bits, air density, etc.  The information is obtained from the header portion of the image 
file. 

1. Select Image Information... from Tools menu.  Image Info window appears. 

NOTE- Bone Value is expressed in Hounsfield Units.  
Information cannot be edited from within this text box. 
2. Click x to close window. 
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Section 3.2  MicroView Processes

MicroView allows you to perform a number of image manipulation routines on the image. These 
are shown on the "Process" tab, and include: 
• Downsampling the image,
• Inverting the image,
• Smoothing the image (Gaussian smoothing),
• Blanking out or masking the area inside or outside the ROI,
• Resampling the volume,
• Reorienting the volume. 

Each of these is explained further below. 

3.2.1 Downsampling the Image

This feature allows you to downsample a 32-bit or 16-bit image into a 8-bit image. This reduces both  
file size and image resolution.

1. Select Image Downsample from Process menu. Process begins automatically and 
downsampled image is shown on the screen. 

3.2.2 Inverting the Image

This tool allows you to create a negative of the selected image. 

1. Select Image Invert from Process menu. Process begins automatically and may take a few 
seconds to complete. Inverted image is shown on the screen. 
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2. Apply Image Invert again to restore the image to its original state. 

3.2.3 Applying Gaussian Smoothing

When selected, applies Gaussian smoothing to the image data and redraws the image. 

NOTE- This process cannot be undone by re-selecting the button. The image must be closed 
and re-opened. 

1. Select Gaussian Smooth from the Process Menu.
System prompts for a Smoothing Radius. Default value is 3. 

Non-smoothed                                    Smoothed
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2. Press OK to continue.
3. Process begins automatically and may take a few seconds. New results are shown onscreen.

3.2.4 ROI Blanking 

This process allows you to blank (erase) image data from either inside or outside the defined ROI. 
You may also define a background value to blank.

NOTE- This process cannot be undone by re-selecting the button. The image must be closed 
and re-opened. 

1. Select ROI Blanking from Process menu. A sub-menu appears. 

2. Set the Background value as required. Click OK to continue.

3. Select either Blank Inside, Blank Outside. 

Process begins automatically and results are displayed onscreen. 

Inside Blanked                                   Outside Blanked
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3.2.5 Resampling the Volume

MicroView can perform image downsampling on a loaded image in order to decrease the disk 
space and memory needed to store an image. 
The technique involves tri-cubic interpolation.

NOTE- Resampling will result in reduced image resolution. 

1. Select Resample Volume... from Process menu. Resample Image window appears.

2. Enter desired resampling factor in the text field.
3. Press Resample and Save... button to resample the image and save it to disk.

You are then prompted to name and save the new image file. 

3.2.6 Reorienting the Volume

MicroView allows you to reorient the volume to some new view and then save the reoriented 
image.  

1. Center and orient the cut planes in the 3-D viewport until the desired orientation is achieved. 
2. Select Save Reoriented Image...  from the File menu to save the reoriented image. 

System prompts for a file name and location to save the file to. Click Save or Cancel upon 
completion.
When the file is re-opened it will display the new axes.  

 

 the output image size

Defines the factor used for
 binning pixels and hence

Non-Reoriented                                   Reoriented
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Section 3.3 MicroView Visualization Tools

MicroView provides a number of  image visualization tools. These allow you to:
• Create a MIP (Maximum Intensity Projection) image,
• Render the volume,
• Create an isosurface from the image,
• Overlay Geometry onto the image,
• Perform an Alpha Blend on the image,
• Make a movie.

Each of these tools is described below. 

3.3.1 Creating a MIP

A MIP or Maximum Intensity Projection image is a volume rendering technique used to visualize 
high-intensity structures within volumetric data. For example, a MIP can be used to extract vascular 
structures from medical data sets. 

The MIP image is produced by casting parallel rays through the image along one of the X-, Y-, or 
Z-axes. Each output pixel in the MIP image represents the maximum intensity value found along 
the corresponding ray cast through the original image. 

This tool is useful when registering a 3D image onto a 2D image.  This can be accomplished by first 
finding the MIP of the 3D image. 

1. Select MIP Image... from the Visualize menu. The MIP Image... window appears. 

2. If desired, select an ROI using one of the available  ROI Tools. The ROI is used to mask the 
image prior to generating the MIP image. This is useful for cropping out high-intensity borders 
surrounding an image, which may otherwise confound the MIP image. 

3. Select desired MIP axis X, Y or Z axis along which to project the image data. 
Oblique MIP-ing is currently not supported. 

4. Click MIP Image button to generate the MIP. 
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5. Use the left mouse button inside the popup MIP window to control the window and level 
settings of the MIP image. 

6. Click the right mouse button to display options for panning, zooming and adjusting window and 
level values for MIP’ed image.

7. Close or Save As... upon completion.  

Pre-MIP                                                     MIP’ed

 Use button 3 to display options
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3.3.2 Rendering Volume 

MicroView allows you to render your 3-D data using the rendering tool.  

1. Select Render Volume … from the Visualize menu.  The Render Volume window appears.

 
2. Click the Update button to activate opacity-based volume rendering. 
3. Adjust the appearance of the rendered volume by editing the opacity and color assigned to 

each gray level value in the image. 
4. To edit opacity select Opacity from the Edit Component menu. 

5. Click and drag the left mouse button across the Color Editor window to adjust that particular 
component. 

6. Repeat steps 4 & 5 for any other components to be edited.
7. Select Render Function option from among the available choices.
8. Select Render Quality from among the available choices. 
9. Click the Update button again once opacity editing is complete. Volume is updated 

automatically.
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3.3.3  Display Isosurface

MicroView's isosurface tool can be used to extract a surface from a 3D image that corresponds to 
a user-defined graylevel value. 

1. Select Isosurface... from the Visualize menu. Display Isosurface... tool appears. 

2. Select an image threshold value in the Isosurface Parameters text box. This grayscale value 
is used for generating the isosurface.

3. Select a surface quality factor. This factor is used to resample the image prior to extracting an 
isosurface. Use a small value (e.g. 0.25) initially to extract a coarse surface, then refine the 
surface by increasing the factor to 1.0. 

4. Press the Surface Color button (as required) to select a new color for the surface. 
5. Select Enable image smoothing as required. 

If selected, the input image is smoothed before the isosurface is generated. Enabling this 
option will generally result in less noisy surfaces. 

6. Select Clip Surface with default ROI as required. 
If selected, determines an isosurface for only (that) portion of the input image within the ROI.

7. Press Show Surface button to display the isosurface.
8. Press Save Surface button to save the surface geometry to disk. The system will prompt for a 

file name and format. Click Save button.   



GE HEALTHCARE
DIRECTION 2407688, REVISION 1 MICROVIEW GUIDE

Page 44  

3.3.4 Overlay Geometry

INTRODUCTION
The Overlay Geometry Tool is used to define, display, and manipulate 3D surface geometry objects 
onto an ROI. 
Three dimensional (or surface) geometries, including those generated using other software tools 
(such as MicroView Isosurface) and other formats (STL, PLOT3D and PLY) can be loaded and 
used in MicroView as a ROI and displayed over top of the loaded image. 

Loaded geometries may be superimposed on top of the current 3D image data. Surface 
characteristics, such as color and whether the object is displayed as a closed surface or a wire 
mesh can be adjusted for each loaded surface. 
Finally, each surface may be selected and assigned as the default ROI for MicroView. This permits 
advanced ROI selections to be saved and restored, as well as allowing third-party tools to be used 
to generate ROI objects. 

INSTRUCTIONS
1. Select Overlay Geometry... from the Visualize menu.  The Overlay Geometry tool appears. 

 
2. Click Load button and select a geometry file to load. 
3. Click Show or Delete to show or hide the geometry. 
4. Click the Geometry ->ROI button to assign the currently selected surface as the default ROI 

for MicroView.
5. Adjust the display characteristics as required by clicking on the Display Wireframe Surface 

Color button. 
System will prompt to choose a color from the palette. Click OK to continue.

NOTE- Multiple ROIs can be loaded simultaneously, each with their own color. 
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3.3.5 Alpha Blend

This tool can be used to alpha-blend (or fuse) one image onto another. 

1.  Select Alpha Blend... from the Visualize menu. The Alpha Blend window appears.

2. Click Load Image... button to select a functional image to be fused onto the image which is 
currently displayed. 

3. To apply a transformation to the functional image click the load Transform... button. The 
system prompts for the file containing the transformation. 

4. Adjust minimum (or maximum) grayscale levels as required using the cursor and slider.
Regions in the image with grayscale values greater or equal to the value (in the case of a 
minimum level) are mapped to a color. Regions with lower grayscale values are transparent. 
The situation is reversed if a maximum level is set. 

5. Click Show or Hide button to show or hide the functional image. 
If the Ramp Opacity option is checked then the opacity of the functional image is ramped 
exponentially. Otherwise the opacity is constant and is determined by the Opacity slider. 

6. The user can select several different color tables. A color table is a mapping of gray scale 
values to RGB color values. 
The Show color scale option is used to toggle the color scale. There are various color tables 
from which to choose.
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3.3.6 Make Movie

This tool allows you to make and save a movie while the image is rotated once around the y axis. 

1. Select  Make Movie... from the Visualize menu. The MovieMaker / Make Movie window 
appears. 

2. Select Movie Type to produce.
Cineloop movies slice through the image from front to back. Y-rotation movies rotate the 
displayed object. 

3. Enter number of images to capture while the image rotates 360 degrees. 
4. Enter a filename and location for the new .avi file, or press the .... browse button.  
5. Click the Make Movie button. 
6. System will prompt you to choose a compression option for the file. Click OK to continue. 

NOTE- Select "Raw" compression format for highest quality movie. 
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Section 3.4 MicroView Analysis Tools

MicroView provides tools to further analyze CT data. These are:   
• Bone Analysis tool,
• Region Grow tools. 
Bone Analysis is explained in a separate section. Region Grow is explained below. 

3.4.1 Region Grow 

INTRODUCTION
The Region Grow Tool is used to define a ROI based on connected voxels with similar graylevel 
values. 
Connected voxels can be grouped together using one of three rules: 
• all voxels with graylevel values greater than a user-defined threshold, 
• all voxels with gray level values lower than a user-defined threshold, or 
• all voxels with gray level values within a range of values centered on a user-defined threshold. 
While it can be used to select an ROI the tool can also operate within the confines of a pre-existing 
ROI, or can be applied to the whole image. 
Region growing is a method of segmentation where an initial seed voxel and criteria for connectivity 
are provided, and then 26 neighboring voxels are examined to see if each one meets the criteria for 
connectivity.  If a voxel meets the criteria for connectivity its neighbors voxels are examined in turn.  
For this tool, the criterion for connectivity is a threshold.   
Region growing is useful tool for segmenting tumors. 

INSTRUCTIONS
Typically a simple ROI is selected to constrain the region growing process. Selecting a small 
rectangular ROI around the object to be segmented will reduce the memory and time required to 
perform the region grow operation. 
Region Grow can be used without selecting a constraining ROI, but the time and memory required 
are greater. 

1. Select Region Grow… from the Analyze menu. 
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1. Move one of the 3D viewplanes so that it intersects the constraining ROI. Select a plane that 
clearly shows a slice of the object you wish to segment. 

2. Temporarily set the Window value for the main window to 1. 
3. Adjust the Level value so that the loaded image is displayed in black and white. Choose a 

setting so that the feature to be segmented is displayed in white. 
4. Select a threshold option from the available list. If segmenting 

- a bright object from a darker background, select upper threshold. The system then 
selects connected voxels with values higher than the current level setting. 

- a dark object from a brighter background, select lower threshold. The system then 
selects connected voxels with values lower than the current level setting. 

- Choose window threshold to segment connected pixels in a range of graylevel values 
surrounding the current level scrollbar value (+/- half the window setting).

5. Pick a starting point (e.g. a pick point) for the region grow operation by positioning the mouse 
cursor over the object of interest within the constraining ROI. 

6. Hit the space key to select the 3D point. 
Once a pick point has been selected, the region grow tool will determine a set of connected 
voxels. The tool will highlight these voxels in green in both the 3D and 2D viewports. In the 
results section of the region grow tool, the volume and centroid of the group of voxels are 
displayed. 

7. Press View Centroid to move the 3D cutplanes so that they intersect at the centroid of the 
selected ROI. 

8. Press Geometry->ROI to assign the results of this tool to the default ROI for further analysis. 
Once assigned, the green highlighted voxels will turn yellow, indicating the new choice of 
system-wide ROI. 
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Chapter 4 Advanced Bone Analysis (Optional)

INTRODUCTION
MicroView's Advanced Bone Analysis Application allows you to perform a variety of analysis, and 
visualization techniques upon a selected ROI. It also allows you to organize, file and store your data 
for future reference.  
Users choose which functions to perform on a given ROI, what type of visualization output is 
required, and in what format the outputted results should be written in prior to any calculation. 

AVAILABLE ANALYSIS TOOLS
The Advanced Bone Analysis Application contains the following tools: 
• BMD - calculates Bone Mineral Density, Bone Volume Fraction (BVF), bone mineral content, 

and various other statistics,
• SMI - calculates Structure Model Index which in turn provides information about the curvature 

of the surface,
• Anisotropy - determines the degree of symmetry and orientation of a trabecular structure,
• Cortical Analysis - When applied to a CT image of a bone, this tool can be used to select an 

ROI corresponding to the cortical shell of the bone. The tool uses a series of morphological 
operators to semi-automatically select cortical bone components. 

• Stereology - reports Euler index, bone volume fraction, bone surface to bone volume ratio, 
trabecular plate thickness, trabecular plate number, trabecular plate separation and various 
other measures. The Euler index is a measure of the connectivity of a trabecular structure. 

• Topology - categorizes each voxel in a trabecular structure as being a member of either a 
surface, curve, or junction and provides a visual representation of this classification, and; 

• Direct Measures - determines the local trabecular thickness of a bone, and provides a visual 
representation of this local thickness. 

4.0.1 Using the Advanced Bone Analysis Application 

Detailed instructions for using the advanced bone analysis tools are shown below.
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1. Activate the Advanced Analysis Tool by selecting Advanced Analysis Tool… from the Analyze 
menu or the Bone Analysis tab on the Tools & Applications toolbar. 

2. If a ROI has not already been selected, select one by clicking either Standard ROI or Advanced 
ROI button. Use Standard ROI to select a box or cylinder ROI. Use Advanced ROI to manually 
select an arbitrary ROI. 

3. Either type in a threshold value in the entry field in the Threshold section or click the Auto 
Threshold button to generate one.

 
4. In the Cancellous Bone Parameters section select the number and type of analyses you wish 

to run. 

1. Choose ROI

2. Pick threshold

3. Select analyses

4. Select options

5. Select output options

6. Select visualization options

7. Run analysis
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5. Click the Advanced Options button to modify the default settings. Click OK to proceed.

NOTE - Advanced Options are discussed in more detail following this section. 
6. In the Output Options section select the type of file and name of the file the results should be 

written to. 

4.0.1.1 Output options and project management
MicroView provides a number of options to help manage your project files and analysis results. 
These are explained below. 

   
7. Load an existing project or create a new one. The system prompts you for project name, 

description and project parameters. 
The project file is stored as .xml.

CREATING AND LOADING PROJECTS
The output data generated by MicroView can be kept as part of a project.  If there is an existing 
project in memory, the "New Project" button will unload that project, and allow the user to define a 
new project for immediate use.
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8. Enter the initial project parameters including the name, description and the number of points 
on each study axis. 

9. Press Next to advance, Previous to return or Cancel to exit. 
10. Enter the names for each axis point in the remaining windows of the wizard.

11. Press Show Results button to have the results of the analyses displayed in a dialog box upon 
completion. 
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12. In the Visualization Options from the available options, RAW, Topology, Anisotropy, or Direct 
Measures. 

   

NOTE- Certain options are only available for selection if they have been selected earlier in 
the Cancellous Bone Parameters section. 

If any one of these options is selected, MicroView will shift focus from the Advanced Analysis 
dialog to the appropriate dialog for visualization when the Run button is clicked. 

13. Click Run to begin the analysis. Depending on the number of analyses selected, it may take a 
few moments to complete.  

4.0.2 Analysis Results and the MicroView Spreadsheets

INTRODUCTION
The results generated by the Advanced Bone Application are shown in a spreadsheet window. A 
typical screen is shown below. 

At the top of the view are tabs which correspond to the available analysis tools. The "ROI Details" 
tab provides general information about the region of interest used to generate the analysis. The 
other tabs display the individual results of each analysis in tabular form. 
NOTE- If the analysis was not selected off in the Cancellous Bone Parameters window, the 
corresponding spreadsheet table will be empty.

 Results are lost upon discard

 Results appear for each selected analysis

 Chose export file format
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The tables for the Direct Measures, Stereology and Cortical tools have an additional features on 
dropdown menus. 
• Direct Measures the additional information that can be displayed is a histogram (bin counts) 

of the thickness and spacing data.  
• For the Stereology, the additional information is the morphological data by axis.  
• For the Cortical tool, the additional information is both the slice-by-slice detailed data, and the 

detailed thickness data.
At the bottom of the spreadsheet window are a number of buttons and other controls, which change 
depending on the type of data being viewed. 

4.0.2.1 Data export options
MicroView provides different file export options and these appear at the bottom of the spreadsheet 
as shown.

Because and these file types organize the data in different ways, these differences are explained 
in detail below.

TEXT AND CSV
The text and CSV files are organized in the similar fashion, and simply use a different delimiter 
between the different data fields.  Text files are tab delimited and the CSV files are comma 
delimited.

All of the data fields are exported to the file.  The file organizes the data output according to the tabs 
that appear in the spreadsheet viewer, so the ROI Details appear first, followed by BMD and so on.  
In the cases where there is additional data (Direct Measures, etc), the additional data begins on a 
new line within the section that it relates to.  Each data section begins with a title, and a header row 
(including units) followed by the data row.

If the data exported is the entire project, then each section contains all of the data for the entire 
project and the lines begin with the project parameters for the specific line.  
NOTE- That respective lines may not match up from data section to data section, depending 
on whether a particular analysis was performed for a given project entry.

EXCEL
The Excel file is organized in a fashion that is nearly identical to the spreadsheet viewer in 
MicroView.  Each tab in the spreadsheet view is given a separate worksheet in the Excel file.  
Further, the additional data components (Direct Measures, etc) are given their own worksheet.  The 
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rows are alternately highlighted to allow for easier separation of the data.  The header rows are fixed 
so that they do not disappear when scrolling the data.

In the ROI Details worksheet, there is an additional column that contains a snapshot of the region 
of interest used to generate the data.

The organization of the rows for exporting data from the entire project into the Excel worksheet is 
the same as described previously for the text and CSV files. 

PDF
The PDF file does not contain all of the available data, but presents a one or two page summary 
view of the data. It is not intended for detailed data analysis.  The top of the page contains a large 
view of the snapshot of the region of interest that generated the data.  Below the snapshot is a table 
that contains selected data points from each of the different analyses that can be performed on the 
image data.

When exporting the data for an entire project to PDF, each individual project entry generates a 
separate report, contained in the same file.  The data is thus separated, and cannot be compared 
easily.
14. Select from among the available Export options.  
15. Press the Export button and the system will prompt you to enter a file name, location and file 

type. Press Save to continue.

4.0.2.2 Adding to existing project 
MicroView allow you to keep the analysis data as part of a project. 
16. Click on the "Add to Project: <project name>" button if they have an existing project.  

NOTE- If there is no project loaded, the Add to Project button will not appear. 

If the analysis data is to be kept as part of a project, the user is prompted to identify the project 
parameters that apply to this analysis.  Once this is done, the user is presented with the 
spreadsheet view containing all of the data in the project.  The data in this view can again be 
exported to any of the four file formats, but in this case, will include all of the different analyses that 
were performed as part of the project.

When viewing the entire project, a new button will appear - "Toggle Project Data".  In the default 
view, each entry in the project is simply assigned a line number.  However, internally, the program 
remembers the project parameters that are associated with each entry.  By pressing the "Toggle 



GE HEALTHCARE
DIRECTION 2407688, REVISION 1 MICROVIEW GUIDE

Page 56  

Project Data" button, the view changes so that the project parameters are explicitly shown in the 
spreadsheet table, or removes them from view if they are present.

NOTE- The "Discard" button will throw away the current results and they are lost forever.  If 
you want to export the results to another file, or keep them in a project, do not use Discard.

The "Close" button closes the spreadsheet view when looking at the data for the entire project.  The 
data is saved to the XML file, and can be viewed again using the "Show Results" button from the 
Advanced Bone Application window.

LOADING EXISTING PROJECTS
1. Use Load Project button to load an existing project.  Provided the project file has the correct 

format, it is loaded together with all the existing data in the file and the project definition.
2. Click on Edit Current Project button and the project wizard will display all of the parameters for 

the loaded project.
3. If you had opened an existing project, the "Show Results" button will show the data contained 

in the entire project using the spreadsheet viewer.
4. Click on Add to Project: <project name> once a project has been defined.  

A dialog is displayed which allows you to select the different project parameters to use when 
filing the output data. The window contains five drop down boxes in the dialog corresponding 
to the five study axes.  By selecting the arrow at the right of the drop down, a list of all of the 
different point labels on that axes is presented and the user can select the appropriate values 
for the analysis being added to the project.
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4.0.3 Advanced Bone Analysis Options

The Advanced Options allow you to modify the default bone analysis settings. 

1. Click the Advanced Options button. 
The Advanced Options dialog contains several tabs which are explained below.
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4.0.3.1 BMD - Bone Mineral Density

INTRODUCTION
This tool performs a virtual biopsy and "ashing" to determine bone mineral content non-
destructively. Image data derived from the Locus family of CT scanners may be calibrated to 
standard CT number, measured in Hounsfield Units (HU), and furthermore calibrated to permit 
determination of equivalent mass of hydroxy-appetite (bone mineral). Results are reported as bone 
mineral fraction (BVF) or bone mineral density (BMD) in units of mg (HyAp)/cm3.
FEATURES

The BMD tab has several variables that can be edited manually. These are: 
• Bone and Water ADU (Arbitrary Density Unit) - By default the values for Bone ADU and Water 

ADU are set to the calibration constants found in the header of image file. 
• Lower Exclusion ADU -The Lower Exclusion ADU is a grey scale value below which voxels are 

not included in the bone equivalent mass calculation. 
• Upper Exclusion ADU - The Upper Exclusion ADU is a grey scale value above which voxels 

are not included in the bone equivalent mass calculation. 
The upper and lower exclusion ADU should be set to exclude air and metal, respectively, in the 
bone mass calculation. 
INSTRUCTIONS
1. Adjust the values in any of the fields to suit and click OK to continue. 
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4.0.3.2 SMI (Structure Model Index) 

INTRODUCTION
Structure model index (SMI) is a parameter used to measure how "rod-like" or "plate-like" trabecular 
architecture is. With aging and disease, cancellous bone architecture in some sites deteriorates 
from plate-like to rod-like. SMI for ideal plates and rods is 0 and 3, respectively. SMI calculated for 
specimens with high bone volume fraction (BV/TV) can be negative.

HOW IT WORKS - ALGORITHM
The SMI parameter is discussed in detail in [Hillebrand97a]. SMI is calculated as 6* (S' * V) / S^2, 
where S' is the surface area derivative, V is the trabecular bone volume, and S is the surface area. 
The factor of 6 is used to obtain integer values for ideal plate, cylinder, and sphere models (plate = 
0, cylinder = 3, sphere = 4). 
The first step in calculating SMI is to create an isosurface of the trabecular bone within the ROI. The 
surface area and volume are directly calculated from this isosurface. The surface area derivative is 
estimated by calculating the change in surface area of the isosurface when the vertices are 
translated a small amount along their normal directions and normalizing by the magnitude of the 
displacement. 
NOTE
SMI was initially used to describe structures with very few intersections between the structure 
elements (i.e., rods and plates) while the BV/TV is low. SMI parameter is always positive for these 
structures. However, if SMI analysis is applied on a dense structure with lots of intersections 
between the structure elements, it may give negative SMI values. This results from the surface area 
decreasing when dilating the surface vertices along the normals and consequently a negative S' in 
the equation for SMI. For example, take a plate with a hole in the center. The hole becomes smaller 
after the vertices are translated in the normal direction and the corresponding change in surface 
area is negative. 
For ROI with more than 22,000,000 (300 x 300 x 300) voxels, the ROI image is resampled by 
shrinking factors 2 x 2 x 2 to reduce memory consumption and speed up calculation.

INSTRUCTIONS

The SMI tab has options to smooth the image prior to the generation of an isosurface and to smooth 
the isosurface prior to the calculation of SMI. 

1. Select or deselect the SMI options as required and click Ok to continue. 
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4.0.3.3 Anisotropy

INTRODUCTION
Anisotropy measures the orientation of the trabecular architecture. This orientation affects the 
mechanical behavior of trabecular tissue and is affected with age and disease. MicroView uses the 
mean intercept length (MIL) method to calculate the structural anisotropy. This method measures 
the intersections of a test grid with the trabecular structure and calculates the fabric ellipsoid (3D 
ellipse) [Whitehouse74][Harrigan84]. Trabecular structures with no preferred orientation have a 
spherical ellipsoid, while structures with more alignment in one direction have the major axis of the 
ellipse aligned in that direction. 

HOW IT WORKS - ALGORITHM
A grid of parallel test lines is passed though the ROI and the number of intersections of the test lines 
with the bone/marrow interface is calculated. This procedure is performed for the number of test 
rotations listed in the advanced options. Each rotation of the test grid is described by two angles 
(theta, phi) in spherical coordinates. For each rotation, MIL is calculated as 2* BV/TV / (number of 
intersections / test line length). The MIL data are then fit to the equation of an ellipse using least 
squares. The least squares analysis provides the 6 coefficients for the best fit ellipse. An eigen 
analysis of the second rank tensor formed by these coefficients provides the length of the axes of 
the ellipsoid and their corresponding directions. The degree of anisotropy is then defined as the 
ratio of the lengths of the maximum and minimum axes. 

FEATURES

The Anisotropy analysis tab has several variables that can be edited manually. These are: 
• Random Testing Angles - When selected, determines whether the direction of the lines used 

when calculating MIL are randomly chosen. 
• Number of Tests -  Represents the number of lines used to calculate mean intercept length 

(MIL).
• Grid Spacing - Determines how finely the ROI is to be resampled prior to any calculations. 

INSTRUCTIONS
1. Adjust Anisotropy options as required and click Ok to continue. 
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4.0.3.4 Direct Measures

INTRODUCTION
Direct Measures calculates the trabecular thickness (Tb.Th) and separation (Tb.Sp) by fitting 
maximal spheres to the trabecular structure. The diameters of the spheres within the bone and 
marrow regions provide estimates of Tb.Th and Tb.Sp, respectively. 

HOW IT WORKS - ALGORITHM
The algorithm is discussed in detail in [Hildebrand97b]. The first step is to binarize the data based 
on the selected threshold. For trabecular thickness, the Euclidean Distance Transform of the bone 
region is calculated. This results in each bone voxel being assigned a value corresponding to the 
distance to the nearest non-bone voxel. Next, for each bone voxel the largest sphere that fits within 
the bone structure is determined. Tb.Th and Tb.Sp are then calculated as the mean value assigned 
to all bone and marrow voxels, respectively.

FEATURES

The Direct Measure tab contains several options, described below. 
• The Minimum Feature Size in pixels can be specified. Structures less than this size will not be 

used in calculating direct trabecular thickness and direct trabecular spacing. 
• In the Direct Measures tab, the user has an option of what measures to compute - direct 

trabecular thickness, direct trabecular spacing, or both. 

NOTE- There is a limitation for ROI dimension which is 650 x 650 x 650. The accuracy of the 
Tb.Th and Tb.Sp calculation is 0.01 voxel. 

INSTRUCTIONS
1. Adjust Direct Measures options as required and click Ok to continue. 
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4.0.3.5 Stereology

INTRODUCTION
MicroView can perform simple stereology analysis of a 3D bone image. The stereology tool 
measures trabecular structure using similar techniques as those implemented in classical 
histomorphometry. 2D techniques determine estimates of trabecular thickness, spacing and 
density. At the same time, trabecular connectivity is quantified by calculating the Euler number for 
the trabecular structure. Finally, the bone surface area to volume ratio is also calculated.

FEATURES

The Stereology tab contains two options, described below.
• Stereology tab - Has an option to enable verbose output to display additional measures.  
• To obtain meaningful results from Stereology, the image should be passed through this 

purification filter first. The purify algorithm removes spurious unconnected region.

INSTRUCTIONS
1. Adjust Stereology options as required and click Ok to continue. 
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4.0.3.6 Cortical 

INTRODUCTION
Use this tool to select an ROI corresponding to the cortical shell of the bone. The tool uses a series 
of morphological operators to semi-automatically select cortical bone components. 
A graylevel threshold value, and two scaling size parameters may be tuned in order to improve the 
accuracy of this ROI tool. 

FEATURES

The Cortical  tab contains a couple of options, shown below. 
• Compute individual slice data -  
• Display radial thickness data - 
After all the modifications to the Advanced Options have been made, 

INSTRUCTIONS
1. Adjust Cortical options as required and click Ok to continue. 
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Chapter 5 Plugins  
MicroView has a number of standard and optional tools to help you analyze MicroCT data.  
Available MicroView plugins are shown on the Plugins menu. They are: 

   

5.0.1 Registration

This plugin can be used to register one image onto another. 

 

1. Start 2 instances of MicroView. 
2. Load a target image into one instance of MicroView and load a source image into the other 

instance of MicroView. 
3. Activate the Registration plugin in the instance of MicroView with the target image by selecting 

Registration... from the Plugins menu. Check the target check box. 
4. Activate the Registration plugin in the instance of MicroView with the source image by 

selecting Registration... from the Plugins menu. 
5. Check the source check box. The 2 instances of MicroView and the Registration plugin 

associated with the source instance will occupy the entire screen. The target image will appear 
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on the left hand side and source image will appear on the right hand side. 
6. Click the Add Points button. 

ADD LANDMARKS
7. Position the cursor over a landmark in either image and then press the space bar. Then 

position the mouse over the homologous landmark in the other image and then press the 
space bar. An arbitrary number of landmarks can be selected. A minimum of 3 landmarks must 
be selected for 2D images and a minimum of 4 landmarks must be selected for 3D images. 

DELETE OR EDIT LANDMARKS
You can delete or edit a homologous pair of landmarks. 

8. First, highlight the row of landmarks by positioning the mouse over a row in the Landmarks 
Selected area of the plugin and press the left mouse button. 

9. Click the Delete button to delete the landmark. To edit the landmarks, position the mouse over 
a new location in the image and press the space bar. 

10. While selecting landmarks the user can undo changes by selecting Undo from the Edit menu. 

SAVING / LOADING LANDMARKS
11. The chosen landmarks can be saved at any time by selecting Save Landmarks... from the File 

menu. The landmarks can be loaded at a later time by selecting Load Landmarks... from the 
File menu. The File menu may not be available in all versions of MicroView. 

SELECT TRANSFORMATION TYPE
12. Select the type of transformation you wish to apply to register the source image onto the target 

image. 
- Rigid Body is a type of transformation with 6 degrees of freedom (i.e. 3 for rotation and 3 

for translation). 
- Similarity is a type of transformation with 7 degrees of freedom (i.e. 3 for rotation, 3 for 

translation, and 1 for uniform scale). 
- Affine 12 degrees of freedom is a transformation with 12 degrees of freedom (i.e. 3 for 

rotation, 3 for translation, 3 for scale, and 3 for shear). 
13. Click the Register button. Once the source image has been registered onto the target image 

save the source image.   
14. Save the source image by selecting Save As... from the File menu in the main window. 

Once the source image has been registered onto the target image, save the transformation    
to a file.

15. Select Save Transform... from the File menu. The transformation can be applied at a later time 
to the original source image by selecting Load Transform... from the File menu. 

16. The two displays can be synchronized by selecting Synchronize Display from the Tools menu. 
It is recommended that this feature be used only after the images have been registered. 

17. Click the Delete All button to delete all the landmarks. 
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